Monday, July 12, 2010

MPLS Service Provider Configuration

MPLS Service Provider Configuration












Here is the basic configuration of MPLS Service Provider with Route Reflector


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cust_C_1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
ip address 10.1.1.1 255.255.255.0
!
interface Loopback20
ip address 10.1.2.1 255.255.255.0
!
interface Loopback30
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 51.1.1.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 10.250.30.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0
network 10.1.2.0 0.0.0.255 area 0
network 10.1.3.0 0.0.0.255 area 0
network 10.250.30.0 0.0.0.3 area 0
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end



!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cust_B_1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
ip address 10.1.1.1 255.255.255.0
!
interface Loopback20
ip address 10.1.2.1 255.255.255.0
!
interface Loopback30
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 51.1.1.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.250.20.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 10
network 10.0.0.0
no auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cust_A_1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
ip address 10.1.1.1 255.255.255.0
!
interface Loopback20
ip address 10.1.2.1 255.255.255.0
!
interface Loopback30
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 51.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.250.10.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 10.0.0.0
no auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end



!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE_1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
ip vrf CUST_A
rd 65000:100
route-target export 65000:100
route-target import 65000:100
!
ip vrf CUST_B
rd 65000:200
route-target export 65000:200
route-target import 65000:200
!
ip vrf CUST_C
rd 65000:300
route-target export 65000:300
route-target import 65000:300
!
no mpls ip propagate-ttl
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
description **** MPLS Lookback ****
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 51.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.10
description description ***** Connected To Cust_A_1 *****
encapsulation dot1Q 10
ip vrf forwarding CUST_A
ip address 10.250.10.1 255.255.255.252
!
interface FastEthernet0/0.20
description description ***** Connected To Cust_B_1 *****
encapsulation dot1Q 20
ip vrf forwarding CUST_B
ip address 10.250.20.1 255.255.255.252
!
interface FastEthernet0/0.30
description description ***** Connected To Cust_C_1 *****
encapsulation dot1Q 30
ip vrf forwarding CUST_C
ip address 10.250.30.1 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
description ***** Connected To P_CORE_ROUTER *****
ip address 172.16.1.1 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
no auto-summary
!
address-family ipv4 vrf CUST_B
redistribute bgp 65000 metric 1000 10 255 1 1
network 10.0.0.0
no auto-summary
autonomous-system 10
exit-address-family
!
router ospf 10 vrf CUST_C
log-adjacency-changes
redistribute bgp 65000 subnets
network 10.250.30.0 0.0.0.3 area 0
!
router ospf 100
router-id 1.1.1.1
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet1/0
network 1.1.1.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.3 area 0
!
router rip
no auto-summary
!
address-family ipv4 vrf CUST_A
redistribute bgp 65000 metric 5
network 10.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 65000
bgp log-neighbor-changes
neighbor 5.5.5.5 remote-as 65000
neighbor 5.5.5.5 update-source Loopback1
!
address-family ipv4
neighbor 5.5.5.5 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 send-community extended
exit-address-family
!
address-family ipv4 vrf CUST_C
redistribute ospf 10 vrf CUST_C
no synchronization
exit-address-family
!
address-family ipv4 vrf CUST_B
redistribute eigrp 10
no synchronization
exit-address-family
!
address-family ipv4 vrf CUST_A
redistribute rip
no synchronization
exit-address-family
!
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback1
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end



!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE_2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
ip vrf CUST_A
rd 65000:100
route-target export 65000:100
route-target import 65000:100
!
ip vrf CUST_B
rd 65000:200
route-target export 65000:200
route-target import 65000:200
!
ip vrf CUST_C
rd 65000:300
route-target export 65000:300
route-target import 65000:300
!
ip vrf forwarding
!
no mpls ip propagate-ttl
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
description **** MPLS Loopback ****
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
description description ***** Connected To P_CORE_ROUTER *****
ip address 172.16.2.2 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 60.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0.10
description description ***** Connected To Cust_A_2 *****
encapsulation dot1Q 10
ip vrf forwarding CUST_A
ip address 10.240.10.1 255.255.255.252
!
interface FastEthernet1/0.20
description description ***** Connected To Cust_B_2 *****
encapsulation dot1Q 20
ip vrf forwarding CUST_B
ip address 10.240.20.1 255.255.255.252
!
interface FastEthernet1/0.30
description description ***** Connected To Cust_C_2 *****
encapsulation dot1Q 30
ip vrf forwarding CUST_C
ip address 10.240.30.1 255.255.255.252
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
no auto-summary
!
address-family ipv4 vrf CUST_B
redistribute bgp 65000 metric 1000 10 255 1 1
network 10.0.0.0
auto-summary
autonomous-system 10
exit-address-family
!
router ospf 10 vrf CUST_C
log-adjacency-changes
redistribute bgp 65000 subnets
network 10.240.30.0 0.0.0.3 area 0
!
router ospf 100
router-id 2.2.2.2
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/0
network 2.2.2.2 0.0.0.0 area 0
network 172.16.2.0 0.0.0.3 area 0
!
router rip
no auto-summary
!
address-family ipv4 vrf CUST_A
redistribute bgp 65000 metric 5
network 10.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 65000
bgp log-neighbor-changes
neighbor 5.5.5.5 remote-as 65000
neighbor 5.5.5.5 update-source Loopback1
!
address-family ipv4
neighbor 5.5.5.5 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 send-community extended
exit-address-family
!
address-family ipv4 vrf CUST_C
redistribute ospf 10 vrf CUST_C
no synchronization
exit-address-family
!
address-family ipv4 vrf CUST_B
redistribute eigrp 10
no synchronization
exit-address-family
!
address-family ipv4 vrf CUST_A
redistribute rip
no synchronization
exit-address-family
!
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback1
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end



!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cust_A_2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
ip address 20.1.1.1 255.255.255.0
!
interface Loopback20
ip address 20.1.2.1 255.255.255.0
!
interface Loopback30
ip address 20.1.3.1 255.255.255.0
!
interface FastEthernet0/0
description description ***** Connected To PE_2 *****
ip address 60.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.10
description description ***** Connected To PE_2 *****
encapsulation dot1Q 10
ip address 10.240.10.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 10.0.0.0
network 20.0.0.0
no auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end




!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cust_B_2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
ip address 20.1.1.1 255.255.255.0
!
interface Loopback20
ip address 20.1.2.1 255.255.255.0
!
interface Loopback30
ip address 20.1.3.1 255.255.255.0
!
interface FastEthernet0/0
description description ***** Connected To PE_2 *****
ip address 60.1.1.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.20
description description ***** Connected To PE_2 *****
encapsulation dot1Q 20
ip address 10.240.20.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 10
network 10.0.0.0
network 20.0.0.0
no auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end



!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cust_C_2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
ip address 20.1.1.1 255.255.255.0
!
interface Loopback20
ip address 20.1.2.1 255.255.255.0
!
interface Loopback30
ip address 20.1.3.1 255.255.255.0
!
interface FastEthernet0/0
description description ***** Connected To PE_2 *****
ip address 60.1.1.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.30
description description ***** Connected To PE_2 *****
encapsulation dot1Q 30
ip address 10.240.30.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 10.240.30.0 0.0.0.3 area 0
network 20.1.1.0 0.0.0.255 area 0
network 20.1.2.0 0.0.0.255 area 0
network 20.1.3.0 0.0.0.255 area 0
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end



!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P_CORE_ROUTER
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
description **** MPLS Loopback ****
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
description description ***** Connected To PE_2 *****
ip address 172.16.2.1 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
description description ***** Connected To PE_1 *****
ip address 172.16.1.2 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 100
router-id 5.5.5.5
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 0
network 172.16.1.0 0.0.0.3 area 0
network 172.16.2.0 0.0.0.3 area 0
!
router bgp 65000
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 65000
neighbor 1.1.1.1 update-source Loopback1
neighbor 2.2.2.2 remote-as 65000
neighbor 2.2.2.2 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
neighbor 1.1.1.1 route-reflector-client
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
neighbor 2.2.2.2 route-reflector-client
exit-address-family
!
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback1
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

1 comment:

  1. Hi!

    Why you have MP-BGP sessions between PE_1 & PE_2 and Core Router?

    ReplyDelete